The server is missing a custom module your files are using


#1

I started running a server off of my computer for my friends and I to play on for fun. I had plugins, workshop mods installed and the players were able to connect to the server but well joining the server they got an error message - “the server is missing a custom module your files are using”. I also get this message when joining the server and I have no idea what it is.

I later purchased a server on Lyhme hosting to not have as much stress hosting on my computer and later found out that this error message still happens on my paid server host.

The only module the server has is Rocket.Unturned. The only module I have on client side is Community.

The plugins installed on server are listed here

The workshop mods installed on server are listed here


Unturned clicking glitch
#2

Screenshot of your personal …\Unturned\Modules folder?


#3

Capture


#4

Also someone told me installing AviZebra would fix the problem because that is a needed dll and I tried it and it still didnt work


#5

Drag that folder out of there and try joining a server.


#6

For anyone with the problem I have this solution worked. Dragging the community folder out lets you join the server but the problem I’m finding is every single person that wants to play on my server has to drag the folder out now?? Or can I just put the community folder module on my server. Will it let players join then?


#7

They should remove it because it shouldn’t be there for them to begin with. In no way should you encourage them to keep it. Straight-up delete the folder, it should’ve been removed when you updated.


#8

Most of my players don’t have the folder but my question is why when I did a fresh install of Unturned last night it still had the community folder. I think it may be a bug nelson will have to fix in the next version.


#9

Are you sure it was a fresh install? To do a fresh install you have to uninstall the game, delete all the folders manually, and delete all the folders from Steam Cloud manually. Otherwise, Steam just pulls from the files you had last time.


#10

I made sure the Unturned folder wasent in the steamapps - common but I didn’t know there was a Steam Cloud!


#11

:man_facepalming: