Unturned Black/White screen error


#21

@MoltonMontro It would be better if you could say which Visual Studio version are you using? I assume 2017 right? It works fine isn’t it? Did you download anything additional with the Visual Studio?


#22

I’m not questioning why you have x86 and x64 versions of the runtime libraries downloaded. I’m questioning the fact that you’re saying your computer is actively running in 32-bit and 64-bit at the same time, which isn’t possible.


A Post Tracking Every Single One Of MoltonMontro's Posts Starting June 16th to July 16th
#23

No my computer runs 64-bit Windows version. I need x86 and x64 versions for the C++ in order to function them properly it has nothing to do with my Windows Version. I’ve downloaded and yet no hope? any way why do you think that it’s happening like this? reinstalled it for the 3rd time and I’m soo frustrated. :confused:


#24

well maybe not if you have a supercomputer, but otherwise I agree XD


#25

No worries, I already understand that, and that’s basically correct. Please read this though:

You haven’t actually addressed my question as to how it’s physically possible for your computer to be a “Windows x86 Operating System (64-bit based).”

Looking at your processor, it seems to support 64-bit, so I’m unsure why you’re calling it a “Windows x86 Operating System (64-bit based).” As far as I can tell based on your specs, your computer isn’t 32-bit (x86).

I recommend not claiming that it is as you’ve done previously throughout the thread, because that’s an entirely different issue if it was actually true. It’s too misleading, and I don’t see a reason for it. “64-bit (x86)” isn’t a thing.

I’m not sure what you’re asking for. Are you wanting a list of every Visual C++ Redistributable I have installed right now?

Different applications use different versions of Visual C++.

  • If your Windows is 32-bit (x86), then it’s more likely to be a memory issue due to the limitations of 32-bit processors.

  • If your Windows is 64-bit (x64), then it’s more likely to be a software issue.

  • You could try running Steam and/or Unturned as an administrator.

  • You could try running Unturned_BE.exe from the Unturned folder.

Is it possible that you have two graphics cards? From the pastebin it doesn’t look like Hybrid-Graphics GPUs are supported on your machine, but it looks like you have an NVIDIA GeForce GTX 1080 and an Intel® HD Graphics 630 (which I assume to be an integrated graphics card?).

  • Try updating the drivers for your GPU(s).

  • If when you right-click an executable and there’s a dropdown for “Run with graphics processor,” try running with the alternative (likely the one that isn’t default) graphics card.


#26

Well, ‘‘Run with graphics processor’’ works only with Laptops not Desktops, I have a Desktop thus, I can’t change it. Also my bad, I taught x86 systems are 64-bit PC’s but yeah to correct it now I have a x64/64-bit Windows/PC. Sorry for all of that wrong information I provided. I’ve down the above mentioned before and after reinstall still no luck :confused:. Also to say that my graphics cards are up-to-date.


#27

Your storage might be full, and it can’t load in everything. Sorry for the SUPER late response, I’m on my way to Ohio.


#28

@KingFrog my storage full? I have 1.65TB Free of storage and only 170GB storage is used. I’ve unistalled my mod’s at the first thinking that’s why my unturned acts like this but turns out it does not! So we can’t blame the storage for that :slight_smile:


#29

Hmm, is it a disk drive or SSD?


#30

At this point I really want SDG Nelson to look into this problem.


#31

@KingFrog my (C:) Drive has most of the core/main applications in it as well as Unturned, now the space in that is 1.65TB free of 1.81TB. I hope this is informative to you?


#32

#Fixed it, finally after 3-4 days of research. It’s easy if anyone is suffering from this. Go to Steam -> Properties -> Launch Options and inside over there type -force-opengl if it says ‘‘initializeenginegraphics failed’’ Then change the -opengl to -d3d9 which will now look like this -force-d3d9 wish you all luck and I would like @SDGNelson to pin this comment as it will be helpful for others to come over the problem I’m facing near future. For those in direct x9 type -d3d9 for those on direct x11 type -d3d11 and for 12 -d3d12


#33

Last but not the least should I use Direct X11 or Direct X12 for the game’s FPS/Performance to improve much better? is the game coded for Direct X12? or not? I have a GTX 1080 and an Intel Core i7-7700


#34

It’s not possible to “pin comments.”


#35

Not necessarily need to pin it, let this be an official fix from my side to the Unturned community :slight_smile: If anyone ever encounters this issue like me in the future.