Campfires can't somehow be placed on vehicles

So I was normally playing survival on France map, when I was about to put campfire on my vehicle. But when it got placed, nothing happened, and I still had my campfire in my inventory.
I tried with crates and they seem to work as normal.
So if you see this, please short fix it!

Certain items can’t be placed on vehicles except blimps and trains, I believe they are campfires, bedrolls, cots, and sentries

Actually, campfires can indeed be placed on vehicles.


I’m guessing what happened is something got in the way as you placed it, since if the spot was obstructed when placing any buildable, it would return to your inventory. This happens for everything from doors to generators. Try repositioning yourself.


Actually, I haven’t been able to place torches on vehicles, and stuff like that. I dunno.

Mother of god.

1 Like

The thing is, I wasn’t even in the way of placing the campfire.
Even I first thought I did, but when I tried it the second time with a bit distance away, it still wouldn’t be able to place…
So I assume it’s a small bug, cuz it doesn’t work on other vehicles as well, such as the Truck or the APC.