Decals in general Do Not Work on any Custom Model (Bug?)

As I was detailing my map, I discovered that ANY decal was not working with any of my custom models.
They would not stick to the models at all as if they were not there. I tried to use the shader in unity (Standard Decalable) with no luck. I even hit up Spyjack for info on why this could be happening, and he told me to add “Asset bundler version 2” to the model’s .dat file. This changed nothing outside giving it a strange white filter over the model as if it was a ghost. This also did not change if the decals worked or not. This also applies to workshop decals as they do not work either.

Also note that this only applies to MODELS, as far as I know the decals do work on custom roads and materials.


I’ve seen some other reports of this aswell.

Yeah i have the same problem, idk how to fix xd

Try exporting the models as .content? Don’t know if it can be used for objects but here’s the guide

I highly doubt that would work as NONE of the vanilla models are.content files, they are still normal unity.3d files. I know this because my own models are usable in the devkit as are the vanilla ones.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.