Help adding weather to custom map

I’ve been at this for hours. Literally all I want to do is make my custom map use the exact same weather that Yukon does. That’s it. That’s all I want. I’ve been researching, and looking at tutorials for hourssss. Everything is outdated, everything is confusing. Please please please god help me. This is the last thing I need to do. I have no idea what to do.

1 Like

Just use the same level asset file as Yukon then. Add the following to your map’s Config.json file.

	"Asset":
	{
		"GUID": "537278c5f6eb45198994ff2915d3107b"
	}

Some relevant links:

This is the problem. I’ve done this, I’ve read all of this. Idk if i’m just stupid or if my map is broken because I am 99% sure I did everything right. My config looks like this:

{
“Terrain_Snow_Sparkle”: true,
“Use_Legacy_Ground”: false,
“Is_Aurora_Borealis_Visible”: true,
“Has_Discord_Rich_Presence”: true,
“Category”: “workshop”,
“Visible_In_Matchmaking”: true,
“Should_Verify_Objects_Hash”: true,
“Version”: “3.22.13.0”,
“Use_Underground_Whitelist”: true,
“Asset”:
{
“GUID”: “537278c5f6eb45198994ff2915d3107b”
}
}

I have the “can snow” thing in the editor on, I have the snow level set to .012. I don’t know what else to do.

I went into game and did /weather 22a2d4cf2d0341e08bee3d9557b78d23 and got the snow to fall, but this isn’t actually part of the map is it? This is so confusing and annoying. I just want the damn snow to fall on the map that’s all I want.

So now when I type /weather 0 in game, it deletes the snowfall, but then makes it start up again. Does this mean it’s reading the weather asset? I don’t think it does because I let the game idle for about an hour and there were 0 blizzards, so it couldn’t be reading the Yukon weather asset, right? Does it matter what size the map is? What else besides putting the asset reference into the config file do I need to do?

I input the same exact settings you’ve listed (the Config.json settings, and the in-game Lighting configuration) onto a brand new map and they worked properly.

Perhaps you should tweak your Snow Frequency Multiplier, Snow Duration Multiplier, and Snow Level settings further? Make sure that your Snow Level is actually the intended 0.012, as opposed to something like 0012.000. The default multipliers for frequency/duration is 1.0. Retrace your steps – are you able to get it to work on a new test map?

I copied my config to a brand new map and nothing happened for me. I am using the exact lighting settings that Yukon uses. I’m really not sure what’s happening here. Maybe somebody could download my map folder and just take a look? Something very wrong has to be happening that I can’t see, probably because I only just started learning how to map yesterday and messed something up.

can you take a screenshot of your lighting settings?

This would be helpful. You could upload it to the Steam Workshop, if you’re familiar with how to do so.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.