Problem with setting up a server on custom objects

So I made some custom objects and a custom map to use them in.
The objects work exactly as intended while the map is loaded in singleplayer, but when I put the map onto a multiplayer test server the objects no longer work.
The objects are still shown in the map but you can no longer use their quest interaction with them. As an example one of the objects is intended to teleport you once you interact with it, this works in singleplayer, but once the object is on the server it doesnt teleport you, it still shows you the interaction highlight like in singleplayer but nothing happens when you interact with it.
I have tried everything that I could think of in an attempt to solve the problem but I have absolutly no idea of what to do anymore so well im asking if anyone here has any idea of what to do:
Things I have already tried:
-bundling the objects into the map
-having the objects as a seperate workshop file and using dependancies
-placing the map into the files directly instead of downloading it over workshop.
-Verifying that the objects are properly setup in unity
-Testing with both individual .unity3d files and a masterbundle.

had the same problem with my map, and i never found out a fix either. You could try using other ways to teleport players like NPC.