Problems with airdrops

So I am playing currently on a survival server, I see an airdrop coming so I get in my helicopter and travel to the (currently mid-fall) crate.

I fly to the crate and hover, wairing for the crate to come to the ground, but then when it is like 10 meters from the ground it fucking vanishes.

So then I am thoroughly confused, and later I fly back home, but then I spot something - it’s the airdrop crate, landed at an entirely different location.

This has happened to me on multiple occasions, the first time I found the crate at a different (nearby) airdrop location, the other time it must have landed at a very different location somewhere else on the map.

This has never happened to me before. the fuck is going on? bug or something to do with the server?


I guess try to see if it happens on other servers. I’ll test it on my server aswell. Havent heard of this bug yet though


I tried it in singleplayer and it worked fine. very weird

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.