So, does any of you guys know to fix these problems?


#1

Hello.

So I’m trying to make custom models (and buildings) so people could stop DDOS me for using compound objects, unfortunately I’ve run into some problem that I’ve tried fixing for ages but went nowhere. These are.

My skybox doesn't appear to appears.

I ripped the “Barracks” example and pretty much left it at that, although that didn’t work so I’ve tinker around with it to the point where I’m clueless. Here’s some pictures as some point of reference.

(Skybox’s model)

(Object’s setting)

I don't know how to add slots for doors, windows, garages and hatches

Completely clueless, most of the guides I’ve look up are either outdated or didn’t existed.

I haven't figured out how to move the position of the equipped weapon.

Someone have stated to added “Model_0”, move it and it would “Changed the position” but either than that they didn’t really told me anything else. So yes, clueless.

These are pretty much half of the problems that’s halted the progression, there are more but I probably have it figured out soon. (And that I forgot.) Anyhow. Thanks for all the help you could support.


#2

I’m not the best teacher per say, so I guess I can just help with the first two.

Your skybox doesn’t have a mesh, I’d recommend just taking the one from the example provided in game and switching the model_2 and texture with the ones you made.

Make sure your LOD actually has the models in it and always double check for redundancies with the tags/layers.


#3

I’ve checked “Demo_Building” example instead, but there’s no Model_2 there, only Skybox.
However in the “Object” example there’s indeed Model_2, but the model of it seems too detailed to be a Skybox.


#4

You don’t have to follow it exactly, typically an object has an model (0,1,2) and then a skybox. But some objects can have only a model (0,1) and then a skybox.


#5

I see, what about these “Source” things.

Opened the Model_Source on blender and see alot of stuffs. Anyhow, still can’t open texture_source.
Edit : Tried bundled it and test ingame without editing anything, doesn’t work.