Throwable : missing 'Item' GameObject


#1

Hi !
Few days ago, i tried to make a new mod with some funny throwables, but with every of these, i have the error “missing ‘Item’ GameObject”. I checked up my Item prefab but i didn’t seen anything wrong, tags and layers are correctly set.
So i tried to bundle the exemple and… Have exactly the same problem ! Can this error come from the *.dat ? Or maybe the throwable bundles were updated ?
I can’t reimport the grenade exemple, there is nothing changed since the last time i imported it in my project.

Screens of the the Item GameObject :

*.dat file :

Thanks :slight_smile:


#2

Too big ID number? Isn’t it 2^15 (32768) max


#3

I use this ID format (3526#) since my first mod and never had this problem with any of my vehicle mods or item mods (used it for an old item mod too, and it worked good, but i no longer have it in my game).
The biggest id should be 65535 accorting to official guide.


#4

But try changing it, anyways


#5

I just changed it to 12340 and removed the blueprints to be sure to not break the mod with these lines, but still have the error. looks like there is really something wrong with the Item prefab…


#6

2^16 is the max ID so that’s not the problem (unless you have a mod which has conflicting ID but I doubt that). If you are using bundle tool and have put your item alongside vanilla stuff you need to add Exclude_From_Master_Bundle to your dat file. If you are using master bundles, your folders are likely not 1:1 to what you have in Unity.


#7

Thanks a lot, you solved it :slight_smile:
I didn’t know i had to add this line, i prefer using bundle tool, for no real reasons :smiley:


#8

Glad I could help. It takes less time to use bundle tool but if you are doing a mod with multiple items utilising same model/animation (shirts for example) it saves a lot of space to use masterbundle tool.


#9

Oh, thanks for information, the use of masterbundle wasn’t really clear to me ^^