Unity not bundling properly

First I started off by creating a backpack with a custom mesh which I made in Blender, but soon I noticed that in game the backpack was invisible (I was wearing it, it was just invisible).
So, I then tried making a shirt, this time I only changed the texture. It was visible while I was wearing it, however in inventory it was lacking an icon and when dropped it would be invisible, unless I’d hover over it with mouse, revealing with the outline that the mesh of the dropped shirt was made out of 2 extended triangles, looking nothing like what a dropped shirt should.
In order to test, to make sure I wasn’t doing any mistake in changing files I bundled a file from the examples folder without changing it in the slightest. Of course the result should be an identical object to the one already in game, however that was not the case. What I got was the same error as before.
In other words, there is a problem with how I’ve set up the Unity. Here is what I’ve done: I’ve dragged the Bundle Tool and the Content Tool files into a subfolder in Unity (I called it Tools) and the TagManager asset into the ProjectSettings folder. It works properly as it’s supposed to. So what is the problem? Anybody experienced similar problem before? Because I can’t go making mods with a bug like this.

A screenshot is more useful than text.

Can you take a screenshot of you about to bundle it?

You’re using the wrong version of Unity. Use Unity 5.5.3f1 (64-bit).


Alright, thanks for info.

This was my mistake too when I started with bundling clothing items.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.