Unturned Crashes upon opening




I have recently encountered a bug when trying to run Unturned. Upon opening Unturned, the game will crash. I am running Linux (in case that helps).

I have not experienced any bugs like this before. I also used the old version of Unturned and it worked perfectly.

I have recorded video of the bug, the video is https://youtu.be/FDGmTWrIScs

Upon watching the video, you will notice that you can see most the screen, but you can not see the loading bar.

I have done everything from reinstall Unturned, reinstall Steam, verify integrity of game files and restart my PC.

If anyone knows any fixes I’d appreciate it!


P.S, sorry for shit audio quality!


7.8 GiB Memory
Intel® Core™ i7-3770 CPU @ 3.40GHz × 8
AMD Radeon HD 7700 Series
Debian GNU/Linux 8 (jessie) 64-bit
169.2 GB


Are you sure it’s not because of the top part of the bar?


That is possible, however I am not stating that it is the direct cause, but it is just a characteristic of the bug


Would you mind putting your computer specifications in the post? (Ie GPU)


Is this what you required?

If not. Then SHRUG


There has just been an Unturned update, I am hopeful


Hello all!

The new Unturned update has done nothing to help fix the crash problems!

I am still looking for any fixes or a sign from Nelson


The issue might be coming from the thousand tabs open on your computer
that or your either pressing ctrl+w


I have tried this with my tabs closed and t still bugs.

I also have not been typing ctrl W


how about you uninstall Unturned and reinstall it
can we have a crash log?


‘I have done everything from reinstall Unturned, reinstall Steam, verify integrity of game files and restart my PC.’

I will get a crash log

EDIT: How do you get the crash log


I’m a regular linux Unturned GOLD user with ~1000 hrs and I had the same problem when upgrading to 3.28.x

I run on a 2010 era HP Z800 server with Ubuntu and an older NVIDIA driver … 340.104 (I hope the age of my system isn’t the problem )

When I run tail -f on $HOME/.config/unity3d/Smartly Dressed Games/Unturned/Player.log, the following lines appear when the game hangs:

ArgumentException: An element with the same key already exists in the dictionary.
at System.Collections.Generic.Dictionary`2[System.String,SDG.Unturned.RootContentDirectory].Add (System.String key, SDG.Unturned.RootContentDirectory value) [0x00000] in :0
at SDG.Unturned.Assets.searchForAndLoadContent (System.String absolutePath) [0x00000] in :0
at SDG.Unturned.Assets+c__Iterator4.MoveNext () [0x00000] in :0
at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in :0

(Filename: Line: -1)


Oh … by the way … i’ve uninstalled, reinstalled, switched to the legacy versions, etc. Its only the new version that has a problem.

Any idea what I’m talkin aboot?


Credit to seb

I felt lazy so…


ok … in the logs folder under my local files, there are two files: Client.log and Client_Prev.log

both files have identical content. 12 lines. here they are:

[19:21:17 - 23/01/2019] Steam: App: Unturned
[19:21:18 - 23/01/2019] Translations: Loaded “english” language “SDG” namespace

ArgumentException: An element with the same key already exists in the dictionary.
System.Collections.Generic.Dictionary`2[System.String,SDG.Unturned.RootContentDirectory].Add (System.String key, SDG.Unturned.RootContentDirectory value)
SDG.Unturned.Assets.searchForAndLoadContent (System.String absolutePath)
SDG.Unturned.Assets+c__Iterator4.MoveNext ()
UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

[19:38:08 - 23/01/2019] General: Current backend date: 01/24/2019 01:38:07
[19:38:08 - 23/01/2019] General: Halloween: [10/27/2018 00:00:01, 11/01/2018 23:59:59]
[19:38:08 - 23/01/2019] General: Christmas: [12/10/2018 00:00:01, 12/31/2018 23:59:59]


im no expert but from reading that it sounds kinda fucked


run windows instead


great tec supprt guyz!


11/10 would ask again


Definitely try sending Nelson the crash log via email.

(Nelson’s email : nelson@smartlydressedgames.com)

Don’t have a email account?
Contact him through Discord.

(Nelson’s discord) : SDGNelson#6404

Hope that this problem gets fixed soon!