3.30.5.1 May Have Broke my Game Slightly

To whom it may concern,

I installed the newest update, 3.30.5.1,
But when I loaded into my Unturned Singleplayer game, my modded house was missing,
Same with my modded apparel,
I couldn’t use spawn commands to spawn back any modded items.
For example, I would try to spawn a Bergen Backpack from the Hsi-Ku Arsenal Military Equipment mod, but the backpack won’t spawn.
I even tried resetting my singleplayer world, but no luck.
I turned off and on the cheats option for my world, still no luck.

I’m sorry if I bothered anyone by posting this.
However,
Is anyone else experiencing this as well?
Please talk about this if you are.
Thank you.

Sincerely,
Pa-Chan

1 Like

Don’t want to sound like a dick, but does Nelson do like test runs of the game before he pushes updates? Like this is not the first time something like this has happened after an update. Yeah, I understand he’s a busy man, but still lol.

Afaik, he always has. I can’t recall the manual practices he does, but I’m fairly certain that he usually(?) boots a map up on a server.

Unturned also follows Continuous Integration practices that help to identify when changes to the game break the build. When CI fails then the update isn’t released.

I’ve only seen two people mention this specific issue, and for the other person the issue was that Steam was just straight-up uninstalling their mods.

Given the timing of it I wouldn’t be surprised if it was something with 3.30.5.1 causing the issue, but very few people have the problem and it’s not something that can be easily tested by the community to work out the specific problem. Most people don’t have this problem, and the handful that do wouldn’t have had any reason to document anything that would’ve explained the issue from the player’s POV.

3 Likes

He uses his laptop to test stuff outside of his main computer.

It looks like yesterday there was a Steam bug that uninstalled many players workshop content.

Molton’s correct that there are both a variety of automated tests for each update e.g. that there are no asset errors, and I always test the update in a multiplayer server prior to release.

8 Likes

I think an apology is in order: Sorry for doubting you, and sort of blaming you for this bug that has nothing to do with unturned.

3 Likes

I know this isn’t fully related to this thread but do curated/workshop maps work on a server now without having to upload the bundles folder of the map as a separate workshop item?
Because rio seems to work.

It reminds me of Apocalypse Rising – the Roblox game that had to be rewritten due to every single update breaking the game in some form. The developers had to make Apocalypse Rising 2 to rewrite the platform so they can continue development on the game, because AR1 had outdated after 4 years of existence and outdated and inefficient framework coding.

I feel like it might be something similar to 3.0 tbh.