30 second delay glitch

Extremely weird glitch my friend has had for months. On his screen, everyone is moving like the present, on our screens he is moving 30 seconds behind. When we say jump, it takes 30 seconds for his ingame character to jump. I linked a video to demonstrate. The Glitch

lag/bad ping probably.

1 Like

Definitely not a lag or ping issue because its consistent across all servers. He has great ping (30-50 range) when this issues occur. His computer specs are fine, nothing is running badly, and his frames are high even though that wouldn’t be an issue.

check the game files to see if they are corrupted.

Tried reinstalling, revalidating, tried tons of things. Can you go more in depth on “corrupted”? Like how could we fix that besides reinstalling or revalidating?

I have this too, But I can sort of make my way out of it if I crouch sometimes.

Maybe nice ping on download but poor on upload?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.