August 2, 2019 – Bug Reports + Improvements

Unknown Intent – Moving items around

“Unknown Intent” in this case should acknowledge an issue with max stacking capacity. But it goes a bit deeper than that.

  1. The game does not let you switch spots between two equally-sized items.
  2. The game has an “Area Unavailable” message that pops up even when trying to switch a 1x1 item with another 1x1 item, and it can appear on a pixel-border around the actual item.

Temporarily/placeholder item respawn system

Respawns items until the storage is full, regardless of actual tampering. May or may not be important, given the placeholderness of it.

Snow Tessellation, Snow Occlusion, and Aggressive Culling

The following video is a visual accompaniment to the actual bug reports provided below.

Snow tessellation is wacky, as it raises the actual ground (intentional) but as the player moves the textures are not “visually appealing” to look at. Honestly, I’d say to just make it so that the snow texture stretches more, and always reaches down to the actual ground. The video demonstrates that, by moving through the snow, it is possible to fix the awkwardness of the raised ground texture.

Snow footprints will sometimes break (this occurred in the previous mainline version too).

The tunnel doors tend to get aggressively culled.


Thanks for the comprehensive post!

Good idea switching equally sized items as a fallback, though there might be some complications with that - I’ll investigate. I’ll fix up some remaining cases where the drop message is empty (“unknown intent” is the default) as well.

Will fix the weapon snow occlusion and tunnel door culling!

Tesselating the snow edges has proven to be a surprisingly tricky problem, but I have a few ideas left. Tried one improved approach for this update unfortunately it didn’t pan out well.

Could you elaborate on snow footprints breaking? Unsure whether that means the displacement, audio, or something else.


In the video it was referred to “snow occlusion”, which was the issue where the game would stop doing actual footprints and the game just generates weird depressions around the player.*


AH okay, I believe what’s happening there is the weapon mesh is incorrectly blocking the snow which will be an easy fix.


This isn’t necessarily a bug, it’s probably been acknowledged by now but you can hold your gun out while driving so the steering wheel is moving by itself.

MoltonMontro just helped me confirm that doors are broken on multiplayer and you can’t walk past them. (We tested on and
Edit: I just tried hosting my own server and could walk through doorways. Maybe only the host can get through doors, or maybe (as Molt suggested) the doors could have broken after those servers were left running for a long period.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.