BattlEye error

My Unturned’s battleye has been acting up for as long as I remember now, the error message is something like Battleye failed to initiate I think. I have looked it up and tried everything I possibly could have. Please, I really want to play again.

What exactly have you tried up until now?

1 Like

I have ran install_battleye.bat, ran as admin as well, ran uninstall_battleye and install_battleye, ran Unturned_BE, ran the non BE one and ran the BE one, whitelisted battleye on windows defender firewall, that’s what I can think of, I’m really stuck.

Ye those would have been the defaults along with reinstalling the whole game.

It would be helpful if you provided the actual error message, as opposed to a recollection of it. My assumption is that it’s a generic error, and it may be that your antivirus is blocking BE (temporarily disabling real-time protection would resolve such an issue), or the install files are corrupt and you need to do a clean reinstall of those files (deleting the BE files and then verifying game cache to repopulate).


I’ll delete the battleeye folder and Unturned_BE and provide the message, let you know if it works.

BattlEye: Service is not installed or not running properly, please restart from the launcher, if you uninstalled BattlEye or skipped the installation step then you can reinstall it using the Install_BattlEye.bat script from your Unturned/BattlEye. Before this message I got BattlEye: Bad Packet.
Edit: Uninstalling Battleye folder and Unturned_BE didn’t work.
Edit 2: Turning off real-time protection had no effect.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.