BattlEye failed to install

09:57:36: Starting BattlEye Service…

09:57:36: Failed to start BattlEye Service (1053).
09:57:36: Installing BattlEye Service…
09:57:39: Failed to install BattlEye Service (4, 41d).

help, how to fix it

Have you tried uninstalling unturned and then reinstalling? I had the same problem a while back and that fixed it.

1 Like

if not, I believe you can manually install BE from its website.

No, you can’t. BE is always installed alongside the game it’s for – it is dependent on that game to function.

Things to try:

  • Verify game cache (just uninstalling and reinstalling isn’t the same).
  • Run the BE installer manually from the Unturned folder.
  • Make sure your firewall/antivirus aren’t blocking BEService.exe and BEService64.exe (located in the BattlEye directory).
  • Make sure your OS is up-to-date.
  • Launch BELancher.exe as an administrator.
  • If you don’t normally shutdown your PC (e.g., run it in Hibernation, Sleep, or just raw), you should properly do a clean boot and launch the game again.

oh, that’s what I was thinking about.


i did all the things from up and didnt change , was the same problem.

On mobile at the moment. Try:

  • make sure all drivers are updated
  • run an anti-malware scan
  • launch Unturned BE.exe as admin
  • launch Steam as admin
1 Like

I had this issue with a different game, the issue may simply be that you don’t have enough storage on your hard drive. Make sure there is space free on it.

“2 months later”

1 Like

Is this a record for most necros by a new user within a week of joining?

@Robnewww Please try not to bump threads that are older than 2 weeks, it pings every person who was active in the thread or was tracking it.


Don’t track the post lol, but fair enough.

My apologies for attempting to help.

It auto-tracks if you reply to the post, also nobody would take their time to manually untrack each post over 2 weeks old.

Sir, you just necroposted on a thread that was 2 months old. I’m asking you to please avoid doing so. I do appreciate that you’re trying to help but reviving an old thread is the opposite of that.

1 Like

Yeah just don’t necro, especially on a support thread where the issue has likely already been solved.


I replied since I saw no solution, my apologies.