[BUG] GUID Reference not working in NPC Vendor's "Selling_0_ID"

Hi, as of the new update, I’ve decided to revamp my NPCs to use the GUIDs instead of the 16-Bit IDs. Everything has worked fine, until I entered the GUID of a supply item into the “Selling_0_ID” section.

Here a few screenshots:

GUIDs aren’t supported with vendors yet (Thanks loco)
And “amount” doesn’t work

Yup, GUIDs don’t work inside of Vendors it seems like.
Not to mention that Amount won’t work as well, I tried using Amount on one of the vendor items and it still spawned the vehicle.

Well actually, GUIDs work normally in the vendors, just not on “Selling_x_ID” and “Selling_x_Condition_x_Quest ID”, which just seems weird to me.

(Also good to mention: Quests are completly unsupported when it comes to GUIDs)

I’m 100% certain it just doesn’t work inside of vendors yet.


image

Just the selling, which is the most important one.

Alright, seems like I misunderstood you a bit, sorry.

nah, my fault, I sometimes use less words to express something xD