Can't connect to modded servers (Vanilla works fine)

Okay, since last sunday, my Unturned has been getting stuck on the loading screen when connecting to a server. And to make sure, I am connecting to a modded server. Vanilla has worked fine. Anyways, I have tried the steam discussions AND the Unturned discord server.

I have tried:

  • Restarting the game
  • Restarting Steam / Logging out
  • Reinstalling the game
  • Verifying cache (too many times)
  • Unsubscribing / resubscribing to workshop mods
  • Restarting my computer
  • Turning off cloud sync
  • Resetting my entire computer
  • Making a new steam account
  • Moving the installation to a different drive
  • Launching the game in administrator mode
  • Doing everything in this list twice

Note: This happened randomly, it worked smooth the night before.
If you need, I have a i3-7100, 1050ti and 8gb of ram with a terabyte of HDD (And a 200gb ssd).

Update: Problem still happening. Just tried using them in single player. Could not spawn them (And yes, I restarted the game and made sure I typed the right command / id). Also I checked the steam files after subscribing to some of the mods, D:\Steam\steamapps\workshop\content\304930 and there they are.

Next time categorize your posts.

Also, this has been a bug for quite some time. Perhaps it’s the mods in the server itself that’s causing the problem since that’s the only common variable across all these conditions.

Whoops sorry. Do you know if there is any fix that could help to solving the problem?

Do all of the above at once.

Also would have suggested clean reinstall followed by clearing out residual files but you literally reset your computer so…yeah just going to wait for others to comment

Manually install a the mods on that server before trying to join.

Sometimes it’s the download time for the mods that force you to take time to load. Because I once went on a server with +500 weapon mods and a bunch of shit.
It took me so fucking long to load in, but I did eventually