Confusion surrounding the new weather system

So I recently opened up an old map of mine that used devkit snow nodes, and when I started to play it and run the blizzard command, it didn’t work. when I went into the devkit to check it out, the snow nodes required an ID (presumably for snow). But I can’t seem to find the ID for it anywhere in the files, and I tried using the GUID, but it canceled out every time I exited the window of the weather node. (i think because it’s too long). I would appreciate some insight on this issue.

1 Like

Hmm existing maps should have been automatically converted. When you select your snow volume does it say Weather_Mask is 2? France used the snow volumes as well.


No, it said the snow mask was “4294967295”, not 2. I also tried to make 2 effects go onto a custom weather asset, but it canceled them out due to it being 2, or didn’t work as is, not sure which.

edit: ive also validated my files twice

1 Like

Sorry, my answer was backwards. For compatibility older volumes will have their mask set to 4294967295, and disable 2 or 1 if snow or rain were disabled respectively. If snow was disabled in the volume then the value would be 4294967293. Based on that value I would expect it to be snowing while you are inside the volume and snow is active (/weather blizzard). Is that the case?

1 Like

No actually, when I did the /weather blizzard command (or @weather blizzard) it still didn’t work (inside the nodes) , sorry for taking so long to reply, my powers been on and off today.

1 Like

Just double-checked this on the Destruction map and I wonder if you have “Use_Legacy_Snow_Height”: false in your Level.config file? If not, it will default to true and the height snow will take priority.


That seemed to have fixed it! thanks. but I have 1 more concern, I noticed for the example custom weather when I try to run it the flames that are supposed to show up don’t show up. I also tried to make my own custom weather and the particles didn’t work on that either, even though they are all vanilla assets.

Edit: After testing it a lot, the snow does work, but it shows up outside of the weather volumes, so the entire map is snowy when it should be only a portion of the map.

1 Like

Here’s the documentation on making custom weather:

If you want to limit snow to only the weather volumes then you will need to set the Global_Weather_Mask in your level asset. In retrospect I should have done something about that for backwards compatibility. :grimacing:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.