Exception while spawning barricade

working on a barricade to decorate the map (a trap) I realized that when playing, the traps set in the editor disappear and that I cannot set them manually either
There is no error according to the error log, but the external log does detect a problem that is unable to spawn it and a possible ID conflict as cause (I already changed the ID and GUID and it still gives the same error) along with another error when try to equip the item
I originally posted this on Discord but it was instantly deleted by the bot


Barricade and Structure placed in the map editor will only exist if the map is reset before entering the map.

what prank said is correct. does this have to be a barricade or could it be an object?

I worked on a horde map and the barricades placed did not require a reset, although I always reset, even for placing an object

From what I’ve been told, only barricades (traps) can do damage, objects can’t, I still did another one with object and kill Volumes although I’m not satisfied with the results at all

Is Police_Barricade_2 a barricade? It logs the “this is probably an ID conflict” message if it’s not a barricade/structure type item.

It is practically the same .dat of the barbed wire, so theoretically it is a barricade
Maybe that has something to do with it, if I’m honest I have no idea.

Ah, the “this is probably an ID conflict” message is wrong. I will fix that for the next update, thanks.

What does it say under “raised an exception” in the log? There should be more details about what the exception was.


BRRR. . . You want to place the trap of 50080, but the screenshot you gave to Workshop error logs is the error message of 50073, is there no error in the trap of 50080? Like duplicate ids or something?

It was showing that there was nothing in the error log, 50073 was an error because I didnt setup an attack sound on the item Tac_Machete

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.