Game doesn't launch

When I run the game (with battleye on or off) the game won’t launch, it goes through the normal process, icon shows up in the taskbar for about half a second, then it completely stops running.

I have tried:

  • reinstalling Steam
  • reinstalling Unturned
  • verifying game files
  • Running the game exe through the files (not through Steam application)
  • Removing all mods
  • Restarting my computer
  • Running the game as administrator
  • Running in compatibility mode for every possible Windows version
  • turning off Real-time protection in Windows antivirus settings

Nothing has worked. I installed Steam and Unturned only today and it worked before a few days before I reinstalled them, but it doesn’t work now. I’ve tried everything I can think of, what can I do to fix it? I’m not having the same issue with any of my other games on Steam or anything else on my computer apart from Unturned

Is your operating system, and your hardware drivers, up-to-date?

Yeah, I recently updated Windows and reinstalled Steam and all my games. Unturned worked fine before and all my other games on Steam work ok, it’s just Unturned that doesn’t open