How to claim access?

idk where to ask this, but I have a problem with getting access to Unturned II. I recently achieved 1250 hrs of play time and got the invitation ticket. I however have no way of claiming access, and neither do i have Unturned II in my library.
I’d love to know what is going on exactly.


Unturned II will not appear in your Steam library until after you have successfully claimed access via the in-game “Claim Access” button, located above the Stockpile button.


Where have you already looked for the “claim access” button at—are you sure you were in the right area?


Try to do what Tyler said, look for a video on YouTube explaining, and also welcome to the club.


I searched everywhere for it. I checked above the stockpile, in inventory, also when selecting the ticket, still nothing. That is the issue im experiencing

Could this be related to me being a mac user instead of windows?

Edit: I even tried switching to the old GUI to see if it could help. It still doesn’t work


Unfortunately, this would be the issue.

It’s been a while since it’s been stated – but at this time there is currently no support for macOS devices on the private beta for Unturned II.

EDIT: The description of the invitation ticket item will be updated to better provide this information. I’m sorry that you were not aware sooner, but when support is added for Macs you’ll likely hear about it first through the SDG Blog, alongside other outlets we use for communication!


Thank you so much for letting me know. I’ll try it on some windows device.

Sorry for derailing a random topic.


Oh, one more thing that I don’t think i have explained properly: I never claimed access. My only remaining question is: can you claim access on windows only. I know you can only play it on Windows but is the claim access feature (in Unturned 3) also Windows only?

Here is your answer, Unturned 2 right now does not have macOs support. So its exclusive for windows users. ( I have not heared about other OS)

Using Proton on Linux somewhat works, somewhat doesn’t. Most common issue with it is audio and in the past, massive stuttering between frames. This varies from update to update though.

that is the uII beta but the whole problem is about getting access.

What’s the current issue again?

You cannot claim access from a non-Windows device.


that answers all questions, thank you so much!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.