I cant play unturned and idk why

i was playing unturned and got off for a little bit and got back on about 1 hour later with theonly things doing while off was dowloading a gmae and chageing the things i can see when looking up games so like i cant see games that are not out yet and i got back om and when i try to join a server it now says “unable to trust host encryption certificate” i googled it but it did not come up with eny thing

sorry about spelling

1 Like

ok first thing where are your periods

secondly maybe its a wifi thing? looking it up a host certificate is used to have secured connection between the host and a user. so maybe you have shit wifi.

I dont have the best WiFi but I didn’t look it to see and i was on unturned a hour before this also so

Sorry about the trouble. We are working with Valve to sort this out, and they asked a few questions:

  • Which platform are you using? For example Windows, MacOS, or Linux.

  • Are you using a laptop?

  • Does it happen consistently for you regardless of server?

1 Like

Following up:

There was a regression in the version of OpenSSL used by Steam. Unfortunately this older version of OpenSSL has a bug with certain laptop chipsets. Valve are going to fix this regression ASAP, probably early next week as part of the usual Tuesday maintenance.

If you are hosting your own server you can set the “-NetTransport=SteamNetworking” command-line option to use the old Steam networking until the fix.

10 Likes

i am on windows i am on a laptop and yes i have tryed like 5 diffrent servers

ok ty thanks for the reply

It has been reported that you can work around it by just setting an OpenSSL Environment Variable to fix it. As Nelson said, OpenSSL is the problem due to specific behavior with laptop CPUs.

Setting
OPENSSL_ia32cap
to
:~0x20000000

Has been reported to fix the problem.

i.e you could make a bat script (if your unturned is installed in the default location) with the following to launch unturned with the fix:
cd C:\Program Files (x86)\Steam\steamapps\common\Unturned
set OPENSSL_ia32cap=:~0x20000000
unturned_BE.exe

(If you don’t know how to do that, just wait for the fix)

1 Like

Can you please tell us how to activate this script step by step, to the smallest detail? I really want to play.

I made a fix.the bat file in which I wrote this:

cd C:\Program Files (x86)\Steam\steamapps\common\Unturned
set OPENSSL_ia32cap=:~0x20000000
unturned_BE.exe

the Game seems to have started, but the server still does not let you in for the same error.

I’m having the same issue with the “unable to trust host encryption certificate” on just a single server which is “Pandahut #9 [Rust] [modded]” while on other servers it doesn’t give me that error? it’s confusing me

Yea, this isn’t working for me either.
Created a .bat in the games root directory
Pasted the 2nd and 3rd line since the first line isn’t necessary when running from the games directory.
Launched it and still getting the error.

Yea depends if the server is using old or new networking. A lot of people have reverted back now, try joining #9 again.

Otherwise, One person told me the bat file/openssl environment change worked, and another in Nelson’s github said it worked for them, but maybe it’s hit or miss. Irregardless of that though, you should be able to join servers using old networking fine.

Will Nelson have an update coming out for this fix so we don’t have to do it manually cause it’s confusing.

That’s on Valve, not Nelson. Update should be deploying some time today

And if doesn’t?

Then you gotta count on server staff

Dam. Didn’t you say there’s a way I can do it myself?

You can try launch arguments, yes.
Or get the server staff to override and use old networking.

I read it have read it and I have not recivivced the 3.20.12.1 upate