I think i've found solution to stuck at loading screen bug "Losing queue" or "Lost position in queue" whatever is called

Only working solution for this ugly bug is to use VPN or change your IP after that it works without any problems for me. I have no idea why is that but it works, it’s weird. Isn’t maybe my IP blacklisted somehow?

I’ve gotten this quite a few times and the only thing that worked for me was restarting the game.

That’s interesting, i have no other way around it. I had this for more than 3 years (by now for sure)
It was really insane struggle when i wasn’t knowing much back then and i wasn’t able to play on servers with friends when they all could, if someone with more knowledge could explain me. Also i made post back in 2018 asking for support/help. It wasn’t any useful, but still thanks to everyone who tried to help me. I will try to see to get new ip from my internet providers. It’s just not easy for me to get new ip address without VPN because that’s situation with my providers… Anyways, it’s kinda sad that this fu* bug still exist. I don’t see any reason what wrong could be with my internet when i have no issues in rest of games i played. Pretty much.

Updating, looks like solution for this bug is to use VPN with Split Tunneling feature, and split tunnel steam.exe to any country you want (probably with lowest latency) And then loading screen bug is gone. I didn’t expect that steam was issue, i though i needed to also tunnel game .exe files including battleye, so basically everything, including steam, now i tried to remove steam and just leave game, it didn’t work, and i removed a game and added just steam and it worked. I can confirm this. Steam you freaking loser, lost a lot of golden days back then when all of my friends played this and i couldn’t.