If you look at the Unturned page from the Steam library, you will see the play button flashing

These are the symptoms. ↓

As you can see, the play button is blinking with “Confirming” or “Play”.
Unturned cannot be started from this screen.

Furthermore, when I try to start the game and play it, the screen freezes repeatedly and in detail.

Is there anything I can do to fix this symptom?

I have tried the following methods.

Uninstall Unturned and install it again.
→It didn’t make sense.

Uninstall Steam and all games and install again.
→The game worked fine in single-player mode, but once I connected to the server, it was not working.
However, as soon as I connected to the server, the screen started freezing and the play button started blinking on this screen in the Steam library as well.
Once this happens, the game freezes even after restarting Unturned.

Checked the integrity of the game files.
→Æ There were no problems.

I thought that the workshop items downloaded from the server were doing something wrong, so I deleted all workshop items on the client side.
→The problem was not resolved.
*Those workshop items were also created by myself and do not contain any files that could cause mischief.
It has been working fine until now.

And, I digress…
Is the location where the workshop items downloaded from the server are saved “\steam\steamapps\workshop\downloads\304930”?
I thought it used to be “\Steam\steamapps\workshop\content\304930”…

Please let me know if you know anything about this.

*I don’t speak English, so I use DeepL to translate.
I apologize if there are any rude or incomprehensible words.

1 Like

Turning off “Save Unturned games to Steam cloud” may have fixed it.
I will try it for a while and report back here.

It was no good.
No solution.
After all, it seems that server participation causes errors.

I’ll try to start it up and raise some things that I feel are different from before.

When joining the server, if there are workshop items that are not subscribed to, they are downloaded during the loading process.
I think the location of the downloaded workshop items used to be “\Steamapps\steamapps\workshop\content\304930”…
I checked and it is now in “\steam\steamapps\workshop\downloads\304930”.

When I looked inside the file of the workshop items downloaded when I joined the server, I found that the .masterbundle was missing or some files were downloaded with missing files.
The file I downloaded at that time was Hawaii Assets.
Steam Workshop::Hawaii Assets

It turns out that just pressing subscribe enters a “confirming” loop…
What can I do…

To clarify: this usually happens if there’s an issue while downloading/installing a game, tool, or Steam Workshop mod. E.g., if the download is corrupted.

Although it could be an issue with your download region. Steam Support provides steps for changing your download region, here: Steam Support :: Slow Downloads and Connection to Content Servers

Steam Workshop downloads for any/all games goes in the ...\Steam\steamapps\workshop\content directory.

The ...\downloads directory is where they’re located while downloading. If there’s files currently in that directory, and you (or someone else) is having trouble downloading mods, then they may be corrupt. Try deleting them, and then restarting Steam. That may resolve th issue.

1 Like

Thank you for your answer.
I tried the method you gave me, but it did not solve the problem.
I have tried everything else I can think of and will describe it.

Change the download region.
→ I have tried many things, including different regions/neighboring countries in my country, but no solution.
If you change the region or delete the download cache, the download itself may not take place.

Deleting files in “workshop\downloads”.
→No solution was found.
Deleting all files in “workshop\content” did not solve the problem.

Delete download cache
→No solution.

Uninstalled and reinstalled “Unturned”.
→No solution was found.

Uninstalled and reinstalled Steam.
→No solution was found.

Stop participating in the Steam beta.
→Uninstalled and reinstalled Unturned.

Check the integrity of the game files.
→No problem.

Temporary suspension of security software.
→No solution was found.
Security software is using Kaspersky.

We use a server with SteamCMD.
Delete the workshop files used for that server.
→The problem was not resolved.

Internet speed and computer environment used
→Download 500mbps
Upload 200mbps
Latency 20ms
Core i7-12700
GeForce RTX3060

Note that—to perform a full, clean reinstall—the steps are:

  1. Unsubscribing from all mods you’re currently subscribed to.
  2. Deleting all mod folders from the ...\Steam\steamapps\workshop\304930 directory.
  3. Uninstalling Unturned.
  4. Deleting the Unturned folder from the ...\Steam\steamapps\common file path.
  5. Reinstalling Unturned.

If you have multiple drives (e.g., an SSD and a HDD), then Steam can sometimes get confused about where your Steam Library is being kept. (Steam Support has an article that kind of mentions this.)

You can configure your Steam Library folders by: right-clicking Steam > Settings > Downloads > Steam Library Folders.


Thank you for your answer.

Uninstalling and installing by the method you taught me
→ did not solve the problem.

Checked where the game was installed from the Steam library.
→No problem.
The files were in the correct location and were specified.

I am sorry that I could not solve the problem even though you told me many times.

However, we have probably found the cause of the problem, although it is not a complete solution.

Manually delete the folder of workshop items in the “workshop\content”
→Subscribe to it from the workshop page.
→The “checking” loop occurs.
Workshop files are downloaded with some missing files.

Perhaps “manually delete folder” was the cause of the error.

If I unsubscribed from the workshop and deleted the files, the next time I subscribed anew, I did not get the “confirming” loop.
It became a normal “play” button.
No files were missing.

Files that were automatically downloaded after logging into the server would also cause an error if manually deleted.

In this case, if you check the installed workshops from the server details, subscribe to all of them, and then unsubscribe, the files in the “workshop”、“workshop”、“content” will also be deleted.

From these results, I think that if you do not touch any of the files in “workshop\content” directly at all, you will not get an error.

This is probably not a complete solution, as deleting them directly was not a problem before, but now I can play Unturned again.
Thanks again for the advice, I appreciate it!

(Please let me know if there’s anything else I should address to get this fully resolved.)


If deleting the Workshop files fixed the issue, then the most likely cause of the issue may have just been that the download was corrupted. In which case, the best solution would just be deleting the corrupted files (which you did).

The only other thing I could think of suggesting would be repairing the library folder. The button to do this is available from Steam > Settings > Downloads > Steam Library Folders > … > Repair Folder.

I get this issue every few days. For me, “verifying game files” usually wards it off for a few more days. I have seen this issue reported by several other community members and it seems to be a uniquely Unturned issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.