Incorrect item lightning

I should probably mention this. The items bundled using master bundle are too bright and seem to be unaffected by environment lightning.


This is a screenshot of weapons I made for a mod I’m currently making and as you can see their textures are unnaturally bright on top of being unaffected by the fact that it’s in the middle of the night. As if they were dimly glowing.

Same issue also happened when I used the Asset_Bundle_Version 2 line in the data file of my helmet of an another older already finished mod in order to be able to render the semi-transparent visor. It’s texture is of exactly same color as the rest of the set, but you can clearly see how it stands out. I just ignored this fact till now, but I think it’s about time to address the issue.

Make sure that the Color Space setting in your Unity project to Linear. You can change it under Edit > Project Settings > Player > Other Settings.

7 Likes

Thanks for help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.