Mac os + battleye trouble

Hello, after new update there is a problem with joining servers. It says this:
“you were kicked from this server because: failed to load BattlEye client library!”
Maybe you know what should I do?

Thank you


Sorry for the trouble! I am investigating to hopefully find a workaround, and will work with BattlEye to get this patched as soon as possible.


A relevant GitHub issue can be found here: failed to load battleye client library · Issue #3233 · SmartlyDressedGames/Unturned-3.x-Community · GitHub

Note that the patch does not include a fix for this issue. We are working with BattlEye to narrow down and patch the issue as soon as possible.


thank you very much. will wait)

1 Like

I shall too, as the same problem has happened to me recently.

This post makes me wonder if some QoL bug fixes could be dispatched for mac os users.

i nned help too mine also says failed to load cuase of battleyee

Lets hope this gets patched soon then

I read the patchnotes #2 but I’m still unclear if this issue has been solved.

It changed, but isn’t fixed, now it says "Unhandled exception when loading battleye client

I see, Thanks. :slight_smile:

Bumping this post to announce that the patch has fixed this issue for M1 Mac players.


one issue solved and another one rises

if I remember well, it takes one or two days for servers to update their versions so it’s normal.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.