Server setup - steam is retrying to connect to servers

I’ve been trying to make my server public but no real luck. Tried making it with Unturned Dedicated Server on Steam and in SteamCMD. I have ports 27015 to 27017 open (TCP and UDP). I can share the IP or make my friends join through “Friends” tab and it works just fine but when I look into server’s commands or into SteamCMD I see “connectivity test: result=Connected, in progress=0” (and it does nothing or repeats itself) and in SteamCMD I see “Retrying…”.
Any ideas? I tried to DMZ the server but no change at all, still accessable through anything but (Steams) “Internet” tab. I’ve looked at couple of forums and tried like 30 different things and still nothing…
EDIT: Iprotant note… tried pinging my server from my PC (my PC and server are 2 different PC’s) and I can’t ping it. (Request timed out.)
Thanks for any suggestions,

The default range 27015 and 27016, but if it works it works I guess.

Anyway what you need to do to get the server listed is to add a GSLT


Well I am positive that helped, but still have the same issue. go 3x k_EResultNoConnection and then 1x in progress=0 (again no changes, stuck at the 0)

I’ve discussed this troubleshooting issue with OP via email. As far as I’m aware, their server is public and working now.

From my understanding, the lack of a GSLT was the main issue, and Deus’ recommendation had resolved that problem. The secondary issue seemed to just be a misunderstanding regarding some of the message outputs by Steam.

I’ve marked Deus’ answer is the solution.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.