Trying to host California on CreeperHost / RocketMod

I have a CreeperHost server and installed the RocketMod Unturned service they have available.

The server works in that I can host and join the default PEI map. I try changing it to Germany, can’t join.

Anyhow, looking to figure out how to get this up and running. I’ve done a lot of Google, but having a hard time piecing together the bit across multiple non-CreeperHost servers. Everything really defaults to “just do this in Steam” but I don’t have Steam on the server.

This is a rather vague question, as you really haven’t provided any information as to why “changing it to Germany” didn’t work, and as such people won’t know why you can’t just “change it to California”.

1 Like

OK… I typed all this and worked through one of my issues. I wish I could give you rubber ducky debug flair.

Ultimately I’m trying to load the new curated California map to the server. Every tutorial, walk through, etc. that I find involved doing things in Steam or on a different hosting platform that doesn’t apply (CreeperHost doesn’t have this control panel that automagically edits necessary files). There is no steam on this hosted server. I’m not finding any documentation as to which configuration files need to be edited and what the values need to be even if I see something that looks pertinent.

The only message I get is “Failed to find [map], defaulting to PEI!” in the console. If I’m lucky it loads PEI, if not I can’t even connect. I recently added the California workshop folder to the workshop folder (Servers/[U-ID]/Workshop/Content/1905768396/ but was then suggested from the console to remove that and add it to the WorkShopDownloadConfig.json. So I did that, editing the file ID line to read: { “File_IDs”: [1905768396], …

Restarted server and the California assets downloaded but still get the map not found, another reboot, another map not found. When I check \U-ID\Servers\U-ID\Server\Commands.dat I have: map CalifROnia which now I realize is bad and when I spell it right it works.

I’m still unsure as to why I can’t load Germany, I will look into that further.

I’m specifying the map via: …\Server\Commands.dat - “map California”

Also on the Workshop, so you’d have the same issue

As California is technically a workshop map make sure your server has it too. Find your workshop directory and then put the map along other maps in ‘Maps’ folder.

1 Like

To clarify some points from this thread:

  • Adding the workshop file ID to WorkshopDownloadConfig.json rather than in the Workshop/Content is indeed the correct way to do it. Manually copying it into Workshop/Content is only still supported for backwards compatibility.

  • Maps from the workshop do not need to be copied into the maps folder, nor do any workshop files need to be manually installed. Everything should work automatically from the WorkshopDownloadConfig.json.

To double-check I hosted a server on California with these steps:

  1. Find the server folder matching my server ID. On the command-line this server is launched with +internetserver/ReleaseSV so I’m modifying files in the U3DS/Servers/ReleaseSV directory.

  2. Added 1905768396 to the WorkshopDownloadConfig.json list. Here is how it may look (albeit with odd formatting on the forum):

“Query_Cache_Max_Age_Seconds”: 600,
“Max_Query_Retries”: 2,
“Use_Cached_Downloads”: true,
“Should_Monitor_Updates”: true,
“Shutdown_Update_Detected_Timer”: 600,
“Shutdown_Update_Detected_Message”: “Workshop file update detected, shutdown in: {0}”,
“Shutdown_Kick_Message”: “Shutdown for Workshop file update.”

  1. In Commands.dat I added the line: Map California

  2. The server console logs that the map has been downloaded:

1905768396 ‘California’ queued for download
1 workshop item(s) to download…
Downloading workshop item: 1905768396
Successfully downloaded workshop item: 1905768396
Installing workshop item: 1905768396
Installed workshop item: 1905768396
Monitoring workshop map ‘California’ (1905768396) for changes

  1. At this point the server should load into the map. Steam should have installed the map into the per-server install directory at U3DS/Servers/ReleaseSV/Workshop/Steam/content/304930/1905768396.

I noticed you marked this as the answer. What ended up being the problem? I’m planning to improve the hosting documentation soon, so it might be good to include there.


Your reply succinctly wraps up what has to be done on a headless server - adding the bit to WorkshopDownloadConfig.json and altering the Commands.dat. That info took me a couple days to put together. Then as to the root of my issue, I mis-typed California as Califronia in Commands.dat which I caught replying to MoltronMontro.

Since this post is titled with “California” I figured your reply wrapped up how best to install Curated or Workshop maps.

I’m still working on the Germany map. Currently replacing the default map installed in \Unturned\ut-instances[U-ID]\Maps with my local copy from Steam. It gets stuck at 8% when loading the level so I’m guessing something must be missing or corrupted. Still have an hour or so on the upload.

I had uploaded my local Germany folder to \Unturned\ut-instances[U-ID]\Servers[U-ID]\Maps and the server loaded the level 100% but then I could not connect.

Unfortunately my server doesn’t seem to support WinSCP’s move feature. And a note to others, use your host’s file manager to delete files, WinSCP takes forever to delete remote files.

1 Like

And now after messing with it, the server drops the connection before I can connect :frowning:

I double-checked and was able to host Germany as well, so it might be worth running steamcmd -validate to get the latest headless files. Depending what kind of dropped connection it is it might be worth contacting the host’s support.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.