Unable to see Model of Modded Weapon ingame


#1

Title.
I’m working on a megaphone model which when fired some words will be heard. The problem is that although the prefab itselft seems to be working alright, as all the elements except the model appear to be working ingame, the model itself does not show up at all. safe to say, the texture is being aplied correctly and everything seems to be just as how it should be when within Unity’s scene.
I’ll make a gallery here: https://imgur.com/a/cbGWqMT
The way i tested it was simple, i just copied some weapon files and deleted the GUID and changed the ID


#2

Have you checked the error logs as you’re ingame with the megaphone installed?

They’d definitely provide insight on the issue.


#3

Make sure tags and layers are set to Item for the model!


#4

Wait, a megaphone gun? YEEEE


#5

I do not know a lot of 3D modeling. All tho I would like to learn more about it because the model looks awesome!


#6

Continuing the discussion from Unable to see Model of Modded Weapon ingame:

Where should i find such logs? there is no crash log files, as it does not crash, and the game log file isn’t reporting anything unusual


#7

In-game, main menu, Workshop, Error Logs.

This should show a list of every single error associated with custom files in your entire game client.


#8

No errors are being shown there anyways. maybe if i give you guys the files you can compile them the proper way?


#9

On one of your images the model file is called Model_0, but the model inside is Circle.001. Rename that to Model_0.


#10

Changing the name of the MESH did not make a difference


#11

Remove LOD 1 and add Culling and drag culled down to 3%. You should have 100% LOD 0 and 3% Culling. Then, click he LOD 0 and click Add. Select your model_0 and recalculate bounds and lightmap. I don’t know what to do with Model_1. I never was taught how to deal with it, I assume you add it to culled

38c349798ef0f321569e4838a08fbf42
Hopefully that fixes it


#12

Added the “triangulate” modifier to the original mesh in blender, still nothing. DGSonic, your suggestion, although helpful as i had not touched the LOD stuff, did not change the outcome


#13

Look, you seem like someone with experience. Can you, like, show me the way it’s done?


#14

Yeah, add me on Discord Dgsonic #1776


#15

Still not Solved


#16

Is your stuff layered correctly, as mentioned above?


#17

I haven’t been able to get it working, but every tag & layer item related is set as item, and i have already migrated the tagmanager from unturned, so everything SHOULD be the same