Unturned II Linux Server Issues

I’m having some issues setting up an Unturned II server running on Linux, and I’m curious if anyone else knows how to get around what I’m facing. When I run the server under a regular user account, (./U4Server.sh), the server’s denied permission for creating some important files and folders. I tried to run under sudo just to see if it would be a quick fix, but it was “refusing to run with the root privileges”, so I’m a bit stuck.

Apparently no log files are generated so I can’t give more than what the console spits out.

Console: UII Console - Pastebin.com

Here’s my U4Server.sh file:
#!/bin/sh
UE4_TRUE_SCRIPT_NAME=$(echo “$0” | xargs readlink -f)
UE4_PROJECT_ROOT=$(dirname “$UE4_TRUE_SCRIPT_NAME”)
sudo chmod +x “$UE4_PROJECT_ROOT/U4/Binaries/Linux/U4Server-Linux-Shipping”
“$UE4_PROJECT_ROOT/U4/Binaries/Linux/U4Server-Linux-Shipping” U4 FiringRange -Log -U4SV=DedicatedServerConfig.ini “$@”

EDIT: Added troubleshooting tag and moved post under U4 Support category

I’ve decided to go back to Windows Server, U4 is being too much of time sink on Linux. Despite solving the error by starting fresh and installing packages required on other UE servers, I was only prompted by more issues that I couldn’t find a way to fix.

I’m disappointed that nobody here saw this post or saw or even responded.