Unturned k_EResultAccessDenied issue for dedicated server

Having issues with an error called k_EResultAccessDenied, after about a day of troubleshooting I found the startup logs and it seems to be a steam login issue. My problem is I don’t understand where I can “log in”. I’ve tried login anonymous in the command line and in commands.dat; but I don’t see the solution in any tutorials or in any past forums. I’d appreciate any help here, thank you guys

End of console log:
[2023-04-30 19:32:22] Waiting for Steam servers... [2023-04-30 19:32:22] Readiness to participate in authenticated communications changed to k_ESteamNetworkingAvailability_Waiting "Waiting for Steam login" [2023-04-30 19:32:25] Failed to connect to Steam servers because k_EResultAccessDenied, no longer retrying [2023-04-30 19:32:25] Readiness to participate in authenticated communications changed to k_ESteamNetworkingAvailability_CannotTry "Failed to connect to Steam"

Could you clarify when/where this message is appearing? E.g., are you trying to download the Unturned Dedicated Server app with SteamCMD currently?

Hi Molton,

This is happening while trying to initialize the server, it seems to boot up fine right up until the very end where it gives me this error.

By command line I meant the batch file I’m using to boot the server up, and as well as the commands.dat file

It looks a lot like it needs to be logged into steam in some compacity, I think I’ve accomplished this before by using login anonymous but with all the changes in recent years to how dedicated servers are setup I don’t understand where to do that at - I could also be mistaken if “login anonymous” is only used in steam cmd when downloading the application.

Rewritten Update: I am going to attempt to follow a guide step-by-step since my prior experience setting up dedicated servers clearly does not translate well.

My troubleshooting today involved utilizing the ExampleServer and despite setting the map, any attempts to join even via localhost resulted in it giving me an error about a modified map. Which brings me to the conclusion that I must have done something wrong while setting it up. This is without a GSLT key set.

With a GSLT key set, in all cases, I was met with the same error as originally stated.

Issue: “k_EResultAccessDenied” error

Solution: Regenerate the GSLT token with the game ID “304930” and apply it via the commands.dat folder with “GSLT [key]”

Reason for error: The game ID used to download the app via steamCMD is not the same game ID you need to generate a GSLT key.

This doc from smartlydressedgames gives you the official game ID to use:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.