Unturned mod works in singleplayer but not in multiplayer

I copied a mod that made some new recipes with vanilla items and added my own recipes to it, this mod works in single-player but not on my dedicated server and I cannot for the life of me figure out why.
I feel like I’ve tried everything

Did you install the mod you created to the Steam Workshop, and then download that mod to your server?

yup, I listed it in the “WorkshopDownloadConfig.json” file and checked that it has been successfully downloaded

Make sure you don’t have the mod installed twice on your client (e.g., locally in your …/Bundles folder or wherever you were working on the mod from, and then again from downloading it via the Steam Workshop to your client when joining the server).

Double-check your server log for errors. https://support.smartlydressedgames.com/hc/en-us/articles/12298951221908

I only ever messed with the workshop files and never touched the bundles folder, I am fairly certain it’s not installed twice because when I disable the mod the recipes stop working in singleplayer but if I enable it again it works again, the same cannot be said for the server for some unknown reason.

I don’t believe the logs will be very helpful as the mod files downloaded to the server are exactly as they should be and I don’t think it displays any errors, regardless maybe you’ll see something that I can’t.

The mod is “Craftable Shtuff” (3128118139)

Thanks for helping! :slight_smile:

There’s an error here, but it shouldn’t be causing your mod to break:

  1. [2024-01-01 06:48:31] Error parsing “E:\Steam\steamapps\common\U3DS\Servers\Apocalypse\Workshop\Steam\content\304930\3128118139\craftable_shtuff\craftable_shtuff.dat”: "duplicate key “Blueprint_1_Supply_2_ID” on line 33 replacing existing value “75” with “67"”

From the server logs, I don’t see any reason why your mod shouldn’t be working when you join your multiplayer server.

If your client has multiple versions of the same mod installed, that would be the most likely explanation for your issues. You could post the logs for your client. Alternatively, the mod you’re using is doing something different that just doesn’t work in multiplayer compared to the mod you were originally using / looking at.

if my client had multiple versions of the same mod installed, wouldn’t the mod continue to work even after being disabled?
If this is not the case how would I check for multiple instances of the mod?
Additionally the mod should be able to work in multiplayer because the mod I used as a guide to add recipes does in fact function in multiplayer and the files do the same things, however my one doesn’t and i have no idea why.

here are the client logs:

thanks! :slight_smile:

It’d depend on what the issue is. You could have a single version of the mod when you join singleplayer, automatically download a different version when you join multiplayer, and then have not played singleplayer again while both mods were installed.

You can always view the mods currently installed from either:

  • The in-game mod menu, which is were you’ve enabled/disabled mods from previously.
  • Your mods folder: ...\Steam\steamapps\workshop\content\304930

I didn’t have an issue running a mod with the same contents on my own server – I can see all/most of the modded crafting recipes fine. Do the other mods installed on your server work? You may consider just trying from a clean state by uninstalling all of your current mods + clearing out your server folder.

It doesn’t look like having set a list of allowed IPs for your mod should be causing issues, but you may consider trying again without it.

1 Like

okay so i finally got it working!
I uploaded an exact copy of my mod to the workshop without a server ID list and tried using a different server to run it and everything is working well
After more testing i found out that it also works on my main server as well, so i assume the problem was the server IP restrictions?

Anyway, thank you so much for the help!
I can finally stop obsessing over trying to get it to work :+1: :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.