Unturned Wont load into Main Menu

Okay so I tried playing Unturned on sunday it crashed within a few seconds of startup, so i did some things to fix it. The next day i try again but this time Unturned would open but won’t load into the main menu, so i tried reinstalling it, backed up the files, verified it. I asked some friends to help, One of them said to verify it so i did, it said 122 files missing. I backed it up and tried playing, Nothing happened just the same thing, So he said to leave it running over night so I did. Nothing happened, Im getting tired of this problem. I use a Linux 64bit Manjaro, it usually can handle Unturned most of the time. I tried deleting some registry in userdata. Nothing.
So it would be nice if i could get some help from an expert or something it aint my PC its just unturned.
Here’s a Screenshot image

Try verifying integrity of game files.

I’ve done that already it said i was missing 122 files so i backed up the files
ill try again.

try uninstalling Unturned and reinstalling it

No need to back any of it up tho.
Aslo, post specs.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.