Updating a local dedicated Unturned 3.0 server (help)

Hello my fellows, I have been having some issues updating my unturned server that I sometimes use to play with my friends lately. I used the SteamCMD method to make it and followed the video guide made by Nelson, and the server worked perfectly. However, with the update I have been unsuccessfully been trying to update it.

I tried going into SteamCMD and putting in “+app_update 1110390,” and I also tried making a shortcut and running the command “C:\ENTER_FOLDER_DIR\steamcmd.exe steamcmd +login anonymous +force_install_dir “GAME_DIR” +app_update 1110390 +quit”

Every time I run the commands or the server, it’s always 3.20.16.

Any help would be apriciated, thanks.

SteamCMD used to shit itself when using anonymous, although that should have been fixed I suggest trying to use a burner, see if that works. Does the process finish with the version just staying the same or does it straight up just quit with an error? (It does sound like the first one but I am just making sure)

I gave it a shot, logging into the SteamCMD didn’t result in anything different, and it is just the same version every time I update it, no errors or anything.

Well shit, that was my best bet. The other option I can think off is just wiping the slate and starting again.

The full reset worked, somehow. Thanks for the suggestion, just wish it had worked before.

Well, you can always try dropping in the existing config and saves bit by bit, see what breaks it.

Do you think it is possible for workshops to block the server’s ability to update? I had around 20 or so on the server, but I’m not sure if that would be able to cause a problem. I re-added them to the fresh server and It works just fine.

In 3.X anything is possible. On a more serious note, I don’t know. On the one hand updating and workshop aren’t really related on a base level. But workshop items for previous versions do exist…

hi, ive been working on making my own online server to play with friends for a couple weeks on and off now and on the 17th i got further than any other days where i was able to connect my gaming laptop to my server running on an other laptop. the problem i was gonna check next was that i could not connect that same laptop over an other wifi signal despite using internetserver and connecting using the bound ip and port (the server didnt show up in lan either but everything worked fine) now as of yesterdday they updated the game so i went and tried to update to 3.20.18 using app_update as it worked from 16 to 17 (that was my problem for the last couple weeks) steamcmd updates the app with no error messages and when i launch back my server it is still on 3.20.17. any tips or help? i tried deleting my server (actually just removing the files from u3ds/server) and when i start my new server it is still on 17. should i try deleting steam cmd and the steam app for the dedicated server?

edit: started again from scratch and still on 3.20.17. will also post this as a standalone question

Running these commands in SteamCMD worked for me when updating from 3.20.17 to 3.20.18
login anonymous
app_update 1110390
I was very suspired on when it worked this time, but I unfortunately can not give much advice. If you weren’t using it before, here is Nelsons official server hosting guide. It might be of some help to you.

and the video tutorial

this is exactly what i used to first create it and app_update is what i used first when the update came out but it didnt update the server. i also started everything over re-following @SDGNelson 'S guide i cant even create a new server on 3.20.18. everything i do leads to a 3.20.17 server

managed to do it by updating app 304930 (unturned game) too. since i used the laptop for server only i didnt think about checking if the game was up to date. wierdly steam updated automatically the dedicated server but left the game on 3.20.17 even if auto updates are on for both.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.