Vanilla objects invisible on workshop map

When the new culling update launched it caused a lot of vanilla objects on the workshop map I’ve been editing to go invisible. I can still select these invisible objects, and if I copy paste them the pasted version appears.
Vanilla objects that have disappeared seems entirely random. In some spots of the map “Metal Fence 2” loads normally in others it’s invisible. In SP and MP players are able to walk into these invisible objects. I tried using the new culling volume features in the editor to no avail.

Any troubleshooting ideas?

Assuming it’s related to object culling volumes, you could verify this by adding the launch option -DisableCullingVolumes to your game.

(Note: this wouldn’t fix your issue, it’d just verify that it’s related to manual object culling. You could also preview object culling from the editor – there’s an option in the Volumes tab.)

Are all of the objects you’re using just vanilla objects?

Adding the -DisableCullingVolumes launch option did verify it’s related to manual object culling. In this case “Fence Metal #2” appears with the launch option.
This map is using a mix of custom objects and vanilla objects. Some of the custom objects didn’t appear either but I was able to fix this with the culling lines in their .dat files.

To clarify, are these objects invisible in the editor as well?

In the editor, there’s a Refresh Objects objects button you can use from the Volumes tab to update which objects are inside culling volumes.

They are invisible in-game and in the editor. I found when I copy paste the objects and make them appear again, they disappear if I click “Refresh Objects” under Manual Object Culling.

Not sure if the culling volumes are supposed to be this large? Most of the custom objects have culling removed.

Edit: I just discovered an object made in 2019 had a very large culling box for some reason. Might have to take a look at it in unity or remove culling on it all together.
Still trying to figure out what’s causing the massive map wide volumes.


Someone had a similar issue not too long ago, with a no-building Player Clip surrounding their entire map. :thinking: Since it was a manually-placed volume, they were able to zoom out a bit in order to select it and delete it.

Nothing should need a culling volume that large. You can technically exclude individual assets with Exclude_From_Culling_Volumes true, but in this case you’d want to just remove the volume covering the entire map.