What are the differences between Bundle Tool and Masterbundle and where to put the files?

Once I got the Bundle Tools from the new package file I am still struggling to get a simple Object in the Game.

I created a simple Testobject with Blender and exportet it to an .fbx-file.
With Unity 2017.4.lts I set up the different “GameObjects” (…, Clip, Nav,…) with meshcolliders.
I also followed the SDG-Tutorial: https://www.youtube.com/watch?v=rAZ9KEGjSUk&t=1371s

Bundle Tool:
I can create a .unity3d-file with the Bundle Tool and created a new Folder for my Object with the needed .dat-file and english.dat-file. The Object is excluded from the Master_Bundle like described in the U3-Docs on GitHub. When I start the Editor the name of my Object exists in the Object-list but it can not be placed. Nothing happens and I also don’t get an Error or anything else. All other Objects are working.

Then I tried implement my Object via the Master Bundle Tool. From the Master Bundle Tool I got the generated masterbundle-files but apparently I messed something up because with this method my Object doesn’t even show up in the Editor’s Object-List.

I’m not sure where are my mistakes.
Subsequent to the recent changes is it possible that someone could make a new detailed Guide for Bundle Tool and Master Bundle Tool.

I can work with Blender but I’m pretty new to Unity so the Unity-stuff will be the most important part.

I tried to find the solution myself but now I got stuck and need your Help.

Assuming you’re only trying to make one object here, stick with the bundle tool.

Some common mistakes that you may of done in terms of the bundletool could be that you:

  • Didn’t name the folder, object.dat and .unity3d file the same thing (They must all be named the same thing, capitalization and all).
  • Didn’t change the GUID or ID of the object in the object.dat file.
  • Didn’t apply your tag/layers correctly in Unity.

This is all I can assume without seeing an actual image of your setup(s), send one over and I’ll try helping some more if none of those were your issues.


I’ll try it again with the Bundle Tool. I’ll make some screenshots of my settings.

I have an Assumption what could be the Problem but I will have the time for testing in the next few days.
It might be the tags. I only entered the tags in Unity which I need for my Object (Small, Navmesh, Clip) and I started entering the tags (ans layers as well) from the first empty line. I guess I have to set up the tag-list exactly like shown in this article: https://steamcommunity.com/sharedfiles/filedetails/?id=849463182
There is apparently the original tag list.
If I understand that right: Every tag must be entered in a specific line according Nelson’s tag-list.
We will see …

Import the project.unitypackage, it includes all of this.
(And the exact tag list is required since it checks for the number not the name)

Exactly this was my problem. I set up the tags again with the ‘original’ taglist and now it works!

Thank you for helping!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.