Guys I have a really old version


#21

No idea, guys?


#22

No, this is a MonoScript


#23

It says it’s somewhere in UnityEngine.dll


Here’s what I found


#24

By the way, this is the output log file shot


And this is PlayerConnectionConfigFile contents
%D0%97%D0%B0%D0%BF%D0%B8%D1%81%D0%B0%D0%BF%D0%B0%D0%BF%D0%B2%D0%B2%D0%B0%D1%82%D0%B8


#25

Gonna sub to this, very interested in old vers of the game, too

Tried to get old vers of Unturned 3.x working to no avail or help


#26

I’m sorry for kinda necropost, but anyways
I’ve managed to launch a beta 160 in an empty menu
I’ve done it easy, by changing dlls, and I located the one I’ll need to disassemble and modify
Here’s a screenshot:


#27

guys i found nelson (not clickbait) (help)


#28

More exactly: if I change Assembly-CSharp.dll. Also I found out that if I changed the Assembly-UnityScript-firstpass.dll on the 206, login menu UI just won’t appear.


#29

And lord @SDGNelson found this thread, maybe he could help me pls?


#30

Assembly-CSharp.dll. Also I found out that if I changed the Assembly-UnityScript-firstpass.dll on the 206, login menu UI just won’t appear. (not clickbait) (help)


#31

@SDGNelson, Where did you hide that server request thing?


#32

My disassembler seems not to like these identifiers :thinking:


nolson why


#33


And here is the page the “register” routine requests


#34

image
Unturned 2 confirmd gaizzz


#35

It seems to be this register routine in Assembly-CSharp.dll, but my editor doesn’t like the identifiers :confused:

Seems like it expects to receive text1 as -1 and text2 as not 666


#36

The same routine for the Steam release does similar thinngs, but gets info from the Steam account.
Direct import of the function results in the bunch of errors

Ok, this is now a blog


#37

Ladies and Gentlemen, we got him!
Finally beta 206 loaded in the main menu!

This version is perfectly playable.
Will start “cracking” 160 version shortly.

Edit: Here is the link


#38

Known bugs:
This version doesn’t save anything, progress void at logout/server shutdown.


#39

And another one gone, and another one gone…

It was “Awaiting game state…” because of some nasty loading screen parameters.
Known bugs are the same
The link.

@Yarrrr, made your treasure playable


#40

If anyone finds another old beta, which is not version 160 or 206, I’d like to crack them, too.