Server on only boots on lan. even if i use +Internetserver/

Hello, I’ve been trying to make a server for me and my friends for a couple weeks and pretty much did it but no matter what i do it is only Lan. I did Nelsons guide about 20 times using +Internetserver/Name binding an ip and port witch are forwarded in the router but the server only opens in Lan. Every unturned instance possible is allowed thru firewall and the servers shows in the steam server console but in the Lan category. What am i missing here? Is there a step that i skipped 20 times or is there something else i need to do in order to have a working Internet server? Any help is welcome. Also i don have any errors running it except some shaders that are unsupported but nowhere i can see in the script either Lan or Internet. Is that normal?

Servers in your LAN will always show in the LAN tab, even when accessible by others.

Make sure it’s going through the right ports, you can check that in the Resource Monitor’s Network tab (assuming you’re on windows)
perhaps you just changed the port number by mistake?

This section here:image

yeah it makes sense but it is not accessible from any other networks (tried it with my cellphone sharing connection on my gaming laptop) i will check Crash solution when i get home but im pretty sure about the port fowarding.

ok i checked in the ressources monitor and i did not see any unturned or unity instance under TCP. i do see unturned linked to port 27015 (twice once ipv4 once ipv6) and 27016 (ipv4 only) there is also a couple more unturned instances to others randoms ports but everything is under listening ports. i will check into that when i get home because remote desktop from work is kinda laggy

Edit: also just to be sure in the command file i should not need to bind any other ports except the first one (27015 here) right? i dont need to write ex.
Port 27015
Port 27016
Port 27017

it should automatically use 16 and 17 if i bind 15 right? (also i know i need to forward ll three)

You can only bind one port (and you’d rarely need to do that). The port range always starts with the specified port.

i think im on something rn our internet provider changed routers and everything a couple months ago and the ‘‘new generation’’ uses an app on the cellphone so i used it to port forward but it wouldnt let me choose the ip so i choose the server laptop in the connected devices but it got the wrong ip (dont ask me why) this whole new generation crap.

Yeah you need to forward all three. Sorry for showing you only the TCP part, I forgot it uses both TCP and UDP.
The one’s I’ve seen lately have two steps in order to forward their ports, one’s the typical Advanced>Firewall settings and the other is in Advanced>Virtual Server (at least in my Arris Router, but I’d assume some others have a similar system and naming scheme).

From then on, it’s just screwing around until it works.

okay something is not working at all. i set up a static ip adress for the laptop and port forwarded 27015-27060 just to be sure that whatever port the server wants to use it can use it (i checked and there is nothing else using these ports) i did tell the server to use 27015 but also tried not specifically setting up a port. both with the server running and not running. all i can see in the tcp category now is unturned.exe using local port 59780 remote port 27036. i can not connect to the server using that port either. tried setting up the port on an other one (ex: 27025) did not work either

here i have set the port forwarding

started the server not asking for a port or ip (only commands rn are Map, Name, Password)
this is what i can see in the ressources monitor. obviously when i came to take a snap the port i was telling you about in tcp just vanished.

if there is something else you’d like to see or anything just ask.

resetted the whole laptop to factory settings and started over and i managed to get a friend to log on at the same time as me but the only way we can connect from an other internet is to go on steam servers and join from there. i cant see the server on unturned even if it is in the Internet steam server list and joinable from there. any tips? any settings i missed?

It sounds like your server is showing up in the server list for other people, just not for you nor your friend. Perhaps an issue with your friend’s server filter settings, for example.

it does show in the steam server list but none of my friends sees it in the unturned server list. all my settings are “any” and i sort by map and i cant find it. i cant even join it from lan, history, favorite. i see it but even if i click on it it doesnt do anything

The fact that someone was able to join from outside your network leads me to believe it is your friends who are having issues, but I can’t think of any possible issues other than what Molton has already mentioned.

Have they tried to connect directly by using your public IP address and port?
I doubt the issue is the server finder/filters, but in case it is using the IP address and port directly should help.

tried both the host machine ip and the “server” ip (wich is different according to steam serverlist) and none of them worked

also i tried on three differents computers two differents internets and all have the same problem. i think the problem is server-sided but i dont know if its a setting in the server or just something else

the server IP should line up with your public IP address, you can check this by just googling “What’s my IP”:

(note this usually changes upon restarting your internet router, so if you have a tradition of turning it off at night, that might be the issue)

Even then, you mentioned one of your friends joining once, which means your server can take players in, I stand by my guess of the issues being their fault and not yours

ok so as you probably guessed it im moving in baby steps but i think i just made an other one about 5 minutes ago.
for the ip adress i set it up static and yes the server can take people in
i screwed around in my steams settings and steam port setting and managed to see the server in the unturned serverlist for the first time tonight the “new” problem is i cant access it. i can click on it but instead of brigning me to the info/join page it just do the click animation/turning white and nothing. i can spam it if i want it does sweet nothing. every other server i tried i clicked once and i showed the join page so i know its a problem with my server (either on my side or steam/unturned side)

in fact the problem is still the same but plus side i can see it in the serverlist. i still cant join it any other way besides from steam serverlist

@MoltonMontro Little update on the unturned serverlist not working

this is what i meant by my ip adress is somewhat different than steam ip adress

Little update i retried logging in with the “steam” ip adress and it works.

Still cant click on it tho. either from favorites, history, internet or lan. but im happy i can now join it from the game directly instead of having to switch back to the desktop and open the steam serverlist

Turns out you were just trying to use your IPv6 instead of IPv4. Well that could have been solved in ten seconds.

1 Like