Unturned 3.21.32.1 Server is not opening ports so others can join

I decided to make an unturned server and i port forwarded the following ports for tcp and udp (27015 to 27018). I know these ports work and i know that they arent blocked because i used minecraft to test the ports and they became open when the minecraft server with those ports launched. Now with minecraft using a different port and it being shutdown i tried to launch unturned server following the official guide by SDG on github i still cant get my server to work publicly. I can only join through lan and not through my public ip. My ip is indeed static, ive tried disabling my antivirius and its firewall along with windows firewall and my routers firewall. on canyouseeme it gives me the error it gives you when the port is forwarded but nothing is listening to it to make it open. An example would be me testing minecraft server port 255564 (just a random number port) it would give me connection refused but when i test the connection again it would say that my port is open. port 27015 gives me the same problem even when the server is running. I used portqry on cmd to see if the ports were listening and that does not seem to be the case. I have also made exceptions on my anti-virus firewall and windows firewall to allow those ports in. I even used resource monitor to confirm that my ports were not blocked by firewall

Try follow my reply in Server Hosting : Lost connection to Host or Steam Network - Unturned / U3 Support - SDG Forum (smartlydressedgames.com)
and check where it stops working (computer, router?)

Got my server running for Lan, but not internet, even though it is configured for internet. Only local ip and localhost work. So I’m in the same boat here, because it refuses regardless what I do.

So it only works in the pc itself?
Check if you portforwarded enough ports in the pc firewall

Everything is as it should in the firewall and router. As far as I can see.