Vehicle doesn't work

Hello guys, i made this car for unturned but when i spawn it. It appears but it’s on fire, the head and taillights are on and i can’t sit in it. I don’t know how i can fix this. Help would be appreciated. :slightly_smiling_face: https://cdn.discordapp.com/attachments/663816836978180130/737600132186374194/unknown.png

1 Like

Lol what dafuq

Have you tried starting the car up

Well i can’t sit in it to start it.

Oh you prolly left the keys locked in the car

Wow your a moron

2 Likes

Still doesn’t explain why it’s on fire XD

It’d be helpful if you provided more information, such as the Unity setup and the .dat file.

The fire could just be an issue with not having put everything you need in the .dat file, such as Health.

If you can drive the car, check that the Smoke and fire’s names are Smoke_1 Smoke_0 and Fire respectively

If you can’t drive the car, please post the unity setup and the .dat file contents to see what we can help with

1 Like

GUID f678db0668e44a66bb03736573e6b021
Type Vehicle
Rarity Legendary
ID 6000

Speed_Min -6
Speed_Max 21

Steer_Min 14
Steer_Max 28

Brake 32

Fuel_Min 0
Fuel_Max 0
Fuel 1750

Health_Min 0
Health_Max 0
Health 550

Trunk_Storage_X 5
Trunk_Storage_Y 3

Explosion 20

Exclude_From_Master_Bundle

This is the .dat file

I can’t drive the car.

That generally happens when there is a problem with the seats. Number, naming, etc.

I have redone my seats and objects but they still don’t work.

This is an issue.

I saw that too and fixed it already but it aint do anything

I can’t see anything that I’d say is particularly wrong atm, but I’ll compare stuff to my setup when I get the chance (should be soon)

Are there any errors in the Error logs?

You can check those in the Main menu > Workshop > Error logs

No there are not

That’s really weird, I’d try redoing the tires and maybe the colliders, but to be honest when stuff like this happens I tend to start over

Yeah i’m going to start over i’ll let you know if it works!